Search found 6 matches

by Retrowaynie
Fri Jan 04, 2019 10:08 am
Forum: The Atari 8bit corner
Topic: Red Screen (of death)
Replies: 6
Views: 9556

Re: Red Screen (of death)

I know it's been a while since last looking at this but since then this is what I done.
I replaced the faulty ic's with LH2164-20's and this made no difference, so my next move is to source original ones and try again.
Back to the drawing board I guess.

RW
by Retrowaynie
Fri Jan 04, 2019 9:57 am
Forum: The Atari 8bit corner
Topic: 2600 mods
Replies: 3
Views: 1693

Re: 2600 mods

Yes it does, very good one.
The old cases can be very brittle, I wonder has anyone thought outside of the box(case) on this one?
I've a few the cases just crumble away.. Its not just limited to the 8bits machines though, I guess.

RW
by Retrowaynie
Fri Jan 04, 2019 7:44 am
Forum: The Atari 8bit corner
Topic: 2600 mods
Replies: 3
Views: 1693

2600 mods

Hi,
What if any, are alternative mods for the 2600?
Other than removing the modulator?
Just curious what other people have done.

RW
by Retrowaynie
Sat Apr 07, 2018 9:33 am
Forum: The Atari 8bit corner
Topic: Red Screen (of death)
Replies: 6
Views: 9556

Re: Red Screen (of death)

Yes, agreed..
Just as a matter of interest, what is the part number of the ram in your machine?
by Retrowaynie
Sat Apr 07, 2018 2:17 am
Forum: The Atari 8bit corner
Topic: Red Screen (of death)
Replies: 6
Views: 9556

Re: Red Screen (of death)

You could try the piggy back method if you have a steady hand that is holding a known good ram ic ontop of each ram ic and see if that weeds out the faulty chip. Desoldering all the ram to socket the board is teadeous alright but doable at the same time. I've got to source some myself to eliminate t...
by Retrowaynie
Fri Apr 06, 2018 4:59 pm
Forum: The Atari 8bit corner
Topic: Red Screen (of death)
Replies: 6
Views: 9556

Red Screen (of death)

Hi, Have an Atari 65XE with an issue, when I switch it on all that's displayed is a red screen. Anyone else had this issue? I read that in an 800XE it is a bad ram issue, installed in my XE are SHARP LH2164-12'S. Done a quick test with my logic probe and didn't get any different reading on any of th...

Go to advanced search