Search found 46 matches

by amilo3438
Thu Dec 07, 2017 10:42 am
Forum: Steem
Topic: Help getting SSE running on this machine
Replies: 10
Views: 3434

Re: Help getting SSE running on this machine

Hmm, it works fine on my XP3...
Try to extract files to a new folder and start from there! (try both d3d and dd versions)
Does it work now?
by amilo3438
Fri Nov 24, 2017 4:42 pm
Forum: Hatari
Topic: Hatari 2.0.0 has been released
Replies: 93
Views: 23110

Re: Hatari 2.0.0 has been released

Yes, it is pretty complicated to sync all this needed exact timings if we want to use more cores. My idea is for example to use core 1 for emu engine loop and other cores for tasks that will be called from this loop anyway and where the core 1 than just continues with what is next! (but I guess that...
by amilo3438
Fri Nov 24, 2017 4:11 pm
Forum: Hatari
Topic: Hatari 2.0.0 has been released
Replies: 93
Views: 23110

Re: Hatari 2.0.0 has been released

Yep, but an powerful CPU with max 1 core performance, as other cores doesn't help much in emulation now. I wonder if display part could be moved on the 2nd core, as it usually only reads/converts screen memory to display!? Also, regarding accurate 68030 emulation, as things looks now, not possible w...
by amilo3438
Fri Nov 24, 2017 3:27 pm
Forum: Hatari
Topic: Hatari 2.0.0 has been released
Replies: 93
Views: 23110

Re: Hatari 2.0.0 has been released

As for the comparison with Steem, simulating a 128 MHz 68000 CPU is not necessarily the same as emulating a 68030 cpu with instruction/data caches ; at similar freq, 68030 emulation is much more complex (and 68030 instructions take less cycles than their 68000 equivalent, so you have more instructi...
by amilo3438
Fri Nov 24, 2017 3:16 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

Sound Demo 3 by Pure Energy --> http://www.pouet.net/prod.php?which=22415

As Sound Demo 1 and Sound Demo 2 work fine on ST/STE (on STE w/stereo sound),
so wonder why Sound Demo 3 refuse to work in STE mode on emu!? (and does it run on an real STE?)

Cheers!
by amilo3438
Thu Nov 23, 2017 6:23 pm
Forum: Hatari
Topic: Hatari 2.0.0 has been released
Replies: 93
Views: 23110

Re: Hatari 2.0.0 has been released

npomarede wrote:could you try with the build from http://antarctica.no/~hatari/hatari-f9d ... b/windows/ for example, as this uses SDL2 ?

Unfortunately, it does not start/work on my WinXP 32-bit system for some reason! (while 2.0.0 works pretty fine) :(
by amilo3438
Fri Nov 17, 2017 4:09 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

And maybe this... STE T162UK 4069K ---------------------- CHANN38 / The Small Demo --> problem with Blade Runners logo scroll! (fine in Hatari or in ST mode) Ps. I finishing with testing demos today! (and than take a little longer break) :) :cheers: Cheers! EDIT: Not sure do you have this problemati...
by amilo3438
Thu Nov 16, 2017 11:39 pm
Forum: Support
Topic: Graphical glitches in 3.9.3 linked to "Wake up" state
Replies: 17
Views: 3683

Re: Graphical glitches in 3.9.3 linked to "Wake up" state

Yes I noticed improvements... this was the main reason for motivation in doing this new demo testing. Of course, this one is not that huge as one did about almost 2 yrs ago (if you remember), but enough to see/check if emu works fine. Btw. I probably finish with testing tomorrow, as only few demos l...
by amilo3438
Thu Nov 16, 2017 8:43 pm
Forum: Support
Topic: Graphical glitches in 3.9.3 linked to "Wake up" state
Replies: 17
Views: 3683

Re: Graphical glitches in 3.9.3 linked to "Wake up" state

Oh, that was a reason, thx.(I understood it wrong) :?

So, in ignore "only some rare shifter tricks are not analysed"! (I get it) :wink:
by amilo3438
Thu Nov 16, 2017 8:21 pm
Forum: Support
Topic: Graphical glitches in 3.9.3 linked to "Wake up" state
Replies: 17
Views: 3683

Re: Graphical glitches in 3.9.3 linked to "Wake up" state

'Ignore' defaults to STF WS3, STE WS1 for the timings but some "shifter tricks" are then ignored, as you saw yourself. Don't forget that this option is available only under 'advanced' settings. Without the latter, a random state is chosen at cold reset. Yeah, I would not find that problem...
by amilo3438
Thu Nov 16, 2017 7:22 pm
Forum: Support
Topic: Graphical glitches in 3.9.3 linked to "Wake up" state
Replies: 17
Views: 3683

Re: Graphical glitches in 3.9.3 linked to "Wake up" state

Thx. for testing on a real machine... So, if its frequent 50%, now depends what someone prefer more, demos or games! :wink: Cheers! Ps. I have no problem if only use STE, as it is sticky now... But as, while testing demos, have to change from ST to STE usually forget to set back to WU2, what knows t...
by amilo3438
Thu Nov 16, 2017 3:21 pm
Forum: Support
Topic: Graphical glitches in 3.9.3 linked to "Wake up" state
Replies: 17
Views: 3683

Re: Graphical glitches in 3.9.3 linked to "Wake up" state

1. Yes, the STE defaults to another state in v3.9.3, because I was told it's more prevalent on real hardware and because it is compatible with some enhanced games that suppose the state corresponds to "WU1" in Steem SSE. The idea is that the dude checking some games knows less than the on...
by amilo3438
Wed Nov 15, 2017 4:21 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

And some more findings... STE T162UK 4069K ---------------------- - Extra Volume 7 / F5 NEXT ... Ze Anti-Mit Intro --> fullscreen glitches! (fine on ST T102) - Extra Volume 7 / F7 TCB ... One-Bit-Plane-Mania --> broken! (behaves better on ST T102) - Extra Volume 7 / F8 TCB ... Swedish demo --> halt ...
by amilo3438
Wed Nov 15, 2017 11:47 am
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

Collection of (so far) findings in v3.9.3: STF3 T102UK 1024K (demos) --------------------------------- - SADENESS --> screen instability in all Wake-up cases! - FROGGIES over the FENCE --> carshes after the intro! - FROGGIES over the FENCE --> after the disk II pics it refuses to return into menu! -...
by amilo3438
Tue Nov 14, 2017 9:51 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

In fact it needs T206UK + 4096K to work w/o any problem! Note: With that config theres also no any bad sound in pdx! (in Bugs.txt is mentioned bad sound in pdx to be correct?) Cheers! Great find! Don't think it was mentioned before. Well, it was mentioned in Hatari's compatibilty.html doc since qui...
by amilo3438
Tue Nov 14, 2017 2:46 pm
Forum: Hatari
Topic: Hatari 2.0.0 has been released
Replies: 93
Views: 23110

Re: Hatari 2.0.0 has been released

Maybe one proposal for the improvement: If in the Floppy disk drive is an .zip file with several images already active, it would be good when next time goto Browse button to see only content of this .zip file until press on Eject button! In current implementation it knows to be pretty frustrating so...
by amilo3438
Tue Nov 14, 2017 2:31 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

STE T162UK 4096K ---------------------- PHALEON / CHAOTIC 2 (or the 2nd demo in main menu) --> in the demo if press F9 key it crash after a while! (Note: Checked in Hatari v2.0 with the same config and it does not crash!) PHALEON / FULLBALL & TNC1 (on the disk 3) --> wont start, just return back...
by amilo3438
Tue Nov 14, 2017 12:06 am
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

STE T162UK 4096K ---------------------- 20 yrs STE / ELITE (in mainmenu the most right) --> 0-9 tunes seem to play too fast! When I checked there were some "problems" (not sure they're the same) on my STE as well, possibly it needs a Mega STE, which isn't emulated yet. In fact it needs T2...
by amilo3438
Mon Nov 13, 2017 3:16 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

More findings but mostly for the info: STE T162UK 4096K ---------------------- 20 yrs STE / ELITE (in mainmenu the most right) --> 0-9 tunes seem to play too fast! (fine in Hatari v2.0 in the 1st test, but in the 2nd test it plays too fast!) BTW. in Steem SSE there is some bad sound present in parts...
by amilo3438
Sun Nov 12, 2017 11:03 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

Just to archive new findings from here --> viewtopic.php?f=94&p=331849#p331849 (Thanks go to lotek_style!)

Hard as Ice demo --> glitches on logo! (Note: needs to wait ca.3 min until it happen!)
(tested config. STE T162UK 1024K)
by amilo3438
Sun Nov 12, 2017 5:30 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

Just for info:
European demos / OVR II --> interesting that Overlander logos gliches in all wake-up states but fine only in ignore!?
(config: STF3 T102UK 1024K!)

Ok, I think that would be all from me for today...
Cheers!
by amilo3438
Sun Nov 12, 2017 4:13 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

Seems there might be some problem with .STW extension demos as for example:
UNION.STW --> wont boot! (fine in SSE v2.8.2) (ataristeven.exxoshost.co.uk/STPRGS/Union%20STW.zip)
(Used config: STF3 T102UK 1024K!)
by amilo3438
Sun Nov 12, 2017 2:51 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

New problem found:
OVERDRIVE / SYNC --> In Audio Sculpture, after mouse left click on the top left corner box it crashes with: HD6301 crashed! (seems fine in 3.9.2)

(Tested config: STF3 T102UK 1024K!)
by amilo3438
Mon Oct 23, 2017 12:26 pm
Forum: Support
Topic: Steem 3.9.3 problem
Replies: 45
Views: 8296

Re: Steem 3.9.3 problem

One more problem: POV162 / 1-Slaytanic Cult 5; reset after loading in v3.9.2/v3.9.3! (works fine in v3.9.1)
Tested config was: STF3 T102 1024K

Cheers!
by amilo3438
Tue Oct 10, 2017 2:23 pm
Forum: Development
Topic: Steem SSE 3.9
Replies: 107
Views: 28235

Re: Steem SSE 3.9

Steven Seagal wrote:It's a long-standing Steem bug. I'll fix it but please put your bug reports in the support section.

It was not a bug report but just an attempt of rescuing from a new embarrassing bug! :angel:

Go to advanced search