Search found 14 matches

by markjw
Thu Jan 17, 2019 1:56 pm
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

well finally good news - got the 555 U104 chip replaced and did a quick power up test - appears to be coming out of reset and attempting to boot from the floppy drive.

Next steps, de-yellow the case (it is more brown than gray) and either re-cap or replace the power supply
by markjw
Mon Oct 29, 2018 8:27 pm
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

ok getting somewhere now!!! Reset circuit is BAD - output on the 555 is floating when the reset button is not pressed so with no input the two gates on U210 are stuck LOW Tied pin 1 of U210 to ground after powering the system up - immediately get HIGH on the CPU RESET PIN and video output. Get the A...
by markjw
Mon Oct 29, 2018 3:53 pm
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

...and take a look at the reset circuit to see what it is doing. I guess you have already answered your own question: ok, got myself a logic probe - results are: BERR - HIGH HALT - LOW RESET - LOW Both RESET and HALT are "active low" signals, meaning your CPU is stuck in reset condition. ...
by markjw
Mon Oct 29, 2018 1:41 pm
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

New TOS 2.06 ROMs arrived and have been fitted - unfortunately no difference to boot - still black screen and CPU RESET/HALT/BERR in the same state. So looks like I'm going to need a scope to check the clock is running and take a look at the reset circuit to see what it is doing. Any further suggest...
by markjw
Mon Oct 22, 2018 3:59 pm
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

I would suspect that the ROMs are at fault. I am not familiar with the STs physical ROM chips but I have seen arcade guys on YouTube with hardware to calculate checksums for EPROMs. That would tell you if they are bad or not. If either of them are bad then you should replace them with known working...
by markjw
Sun Oct 21, 2018 4:00 pm
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

ok, got myself a logic probe - results are:

BERR - HIGH
HALT - LOW
RESET - LOW

Also CPU replaced with one off eBay - same results.
Any way of checking the clock without a scope?
by markjw
Tue Oct 16, 2018 9:18 pm
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

What are the states of the following pins? HALT: pin 17 BERR (Bus error): pin 22 I am thinking that HALT will be low and BERR may be high. As mpattonm says it would be wise to check the clock signal first. thanks to both of you for the suggestions - need to get my hands on a working scope first Cur...
by markjw
Tue Oct 16, 2018 9:50 am
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

just a quick update now I finally have some free time: 1. Checked the voltages on the 520STE PSU - 5.02V on the 5V line and 12.05 on the 12V line 2. 68000 CPU is getting very hot, very quickly still - reseated it - no change 3. Put a meter on the 68000 RESET PIN - first time was getting 4.93V, but o...
by markjw
Sun Sep 23, 2018 11:02 am
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

No, the ROMs from an STF will not work in an STE. There is not that much you can do without measuring instruments. You could try to carefully remove and reinsert socketed ICs in case the contacts are bad due to corrosion. You could try replacing the power supply (e.g. by one from the STF, they are ...
by markjw
Sun Sep 23, 2018 8:55 am
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Re: Faulty Atari 520STe - black screen

troed wrote:Replacing TOS with known good chips is always an easy start. Verify the jumpers are in the correct position for the chips used.


I'll have to see if I can find someone to program me a set - or can the 2 ROM set from a 520STFM be used?
by markjw
Fri Sep 21, 2018 9:30 pm
Forum: Hardware
Topic: Faulty Atari 520STe - black screen
Replies: 22
Views: 4512

Faulty Atari 520STe - black screen

picked up a 520STe the other day, powers up but unfortunately only to a black screen. Someone has had it apart before as all the case screws and those holding the FDD are missing. State of play with it: 1. Power LED is on but no FDD LED on power up 2. TOS ROMs are not original - pair of EPROMS insta...
by markjw
Thu May 25, 2017 8:25 pm
Forum: Hardware
Topic: ST 520STFM dead - suspect psu?
Replies: 5
Views: 1428

Re: ST 520STFM dead - suspect psu?

bit of an update - found a 5v 2A PSU (spare for my IP phone) - was able to do a very quick test using the end of an old 3.5" floppy power cable hooked to it and got a steady power light - couldn't test any further at the moment as haven't found a video cable and the wires I was using were a bit...
by markjw
Mon May 22, 2017 12:16 pm
Forum: Hardware
Topic: ST 520STFM dead - suspect psu?
Replies: 5
Views: 1428

Re: ST 520STFM dead - suspect psu?

cheers, I'll give powering it up just on the 5v line as soon as I get a chance - found the schematic for the psu on here so it the mainboard works I can look at changing out the caps
by markjw
Sun May 21, 2017 10:10 pm
Forum: Hardware
Topic: ST 520STFM dead - suspect psu?
Replies: 5
Views: 1428

ST 520STFM dead - suspect psu?

First posting here so hi to everyone. I have a UK model 520STFM that has not been powered up in at least 25 years. Found it in a cupboard today and thought I would risk giving it a try - power light came on for a second, followed by a crackling sound from the PSU area and the power light going back ...

Go to advanced search