Search found 43 matches

by TeX38
Fri Feb 08, 2019 5:36 am
Forum: Hardware
Topic: Atari ST MMU
Replies: 4
Views: 958

Re: Atari ST MMU

Thanks Greenious, I have a STF(M) service manusl but not the mega one, I'll look i to it. Will a faulty SHIFFTER also stop the ST from booting? Problem with the ST is their being so INTERGRATED, makes is so much harder to troubleshoot. I guess a diag cart would be helpful but i dont have 1. My ST is...
by TeX38
Fri Feb 08, 2019 3:15 am
Forum: Hardware
Topic: Atari ST MMU
Replies: 4
Views: 958

Re: Atari ST MMU

Thank you for ur replies..
I wen back and re checked..

RAS0 is active all the time.
CAS0 H/L = INTERMITTENT waveform
So i suggest the MMU is ok, maybe a ram problem.
by TeX38
Thu Feb 07, 2019 9:38 am
Forum: Hardware
Topic: Atari ST MMU
Replies: 4
Views: 958

Atari ST MMU

Hi, My Atari has failed. Checking around with my CRO shows the expected clocks etc, the Data is there on reset and there is activity on the address lines. RAS is active but CAS is high, no activity at all. When there is a problem with an ST, does the CAS signal get stopped or have I got a faulty MMU...
by TeX38
Tue Jun 20, 2017 11:57 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

In fact, if anyone reading this subject has one hanging around unused I would love to hear from them. I would be interested in just the bare board if available. I still might have one spare PCB. It needs minor modification, but it works relatively well :) Send me a PM if you're interested. Hi Kubik...
by TeX38
Sun Jun 11, 2017 9:12 am
Forum: Hardware
Topic: Another failed ST -> vga experiment for me :)
Replies: 167
Views: 76295

Re: Another failed ST -> vga experiment for me :)

I threw that circuit together last week, it does a great job keeping the image stable. For switching to mono mode I use a vga switcher, and a dpdt switch that either provides 5V for the sync mixer and GBS board, or connects MONO DETECT to ground. It's all mounted in my homemade ST case with a separ...
by TeX38
Tue Jun 06, 2017 5:20 am
Forum: Hardware
Topic: New wiki page - ST low/med/high capable flatscreen monitors
Replies: 75
Views: 31395

Re: New wiki page - ST low/med/high capable flatscreen monitors

Hi Troed, The wiki refuses to display on my computers so can I request that you send me the monitor list so I can see it? I see that you are using a Dell 2001FP for your ST, I have one of these monitors coming and am hoping that it will work on my STF. I see nowhere in the Specs that it supports do...
by TeX38
Mon Jun 05, 2017 11:56 pm
Forum: Hardware
Topic: New wiki page - ST low/med/high capable flatscreen monitors
Replies: 75
Views: 31395

Re: New wiki page - ST low/med/high capable flatscreen monitors

FYI, I've added a new page to the wiki with model names of monitors people have found can accept not only ST high (which most VGA monitors do) but also ST low/medium on their VGA input. If you know more than what I've added, please list additional monitors. http://www.atari-wiki.com/index.php/Multi...
by TeX38
Thu Jun 01, 2017 5:27 am
Forum: Hardware
Topic: Another failed ST -> vga experiment for me :)
Replies: 167
Views: 76295

Re: Another failed ST -> vga experiement for me :)

I recently bought one of those RGB to VGA devices & have produced a pretty good picture by combining H&V sync. http://i22.photobucket.com/albums/b328/scottspikey/th_DSCF4103.jpg http://i22.photobucket.com/albums/b328/scottspikey/th_DSCF4105.jpg http://i22.photobucket.com/albums/b328/scottsp...
by TeX38
Tue May 30, 2017 8:11 am
Forum: Hardware
Topic: Another failed ST -> vga experiment for me :)
Replies: 167
Views: 76295

Re: Another failed ST -> vga experiement for me :)

It's simply Atari..................Converter R-------------------------R G-------------------------G B--------------------------B H Combined >--------------S V The RGB converter is an GBS 8200 V4 Hmm...I have the same board and so far I have been unable to get it to work with my STF. Mine is made i...
by TeX38
Thu May 25, 2017 11:32 pm
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

I am thinking part of the problem with my 1040 is the Glue, there are no Rom strobes at all. Strange, it has been there in my early testing, I guess the Glue has been doing strange things and just maybe has now given up the ghost. A/ The Glue in my 1040 is C070714-001. B/ The Glue in my 520 is C0259...
by TeX38
Thu May 25, 2017 10:59 pm
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

In fact, if anyone reading this subject has one hanging around unused I would love to hear from them. I would be interested in just the bare board if available. I still might have one spare PCB. It needs minor modification, but it works relatively well :) Send me a PM if you're interested. Hi Kubik...
by TeX38
Tue May 23, 2017 8:23 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

The first cycles after reset will be CPU reading content of ROM. You should see CPU reading addresses 0 - 7 and then jumping somewhere to area FC0000 - FEFFFF. In that case, CPU generates the addresses, while ROM provides the data. I'm not sure what's happening next, but I am guessing presence of c...
by TeX38
Mon May 22, 2017 4:11 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

If I am not mistaken, the RAM data signals go through LS244 bus drivers. You'd better check the D6 on both sides of the corresponding bus driver before spending time and effort on removing the SMD chips :) Yep, did that earlier, the waveform on D6 is the same on both sides of the LS244. Enters on P...
by TeX38
Sun May 21, 2017 10:54 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

Hmm, if I understand it right, it looks more like something pulling the D6 high. Did you try to remove all non-important socketed chips (AY, FDC, DMA...)? Thanks Kubik, Sadly most of the chips on the board are not socketed, I have removed ROM, DMA and RAM. Nothing happens at all when I pull the ram...
by TeX38
Sun May 21, 2017 5:44 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

Could it be a ROM fault? Loose socket, perhaps? I removed the ROMs and all data lines came good aside from D6 which is still stuck high, it pulses low by a few millivolts on reset so it is almost a bad Rom problem, not sure about D6 though, probably a buffer. May explain why my working french STF w...
by TeX38
Thu May 18, 2017 8:26 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

Could it be a ROM fault? Loose socket, perhaps? I removed the ROMs and all data lines came good aside from D6 which is still stuck high, it pulses low by a few millivolts on reset so it is almost a bad Rom problem, not sure about D6 though, probably a buffer. May explain why my working french STF w...
by TeX38
Thu May 18, 2017 12:47 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

Are these parts interchangeable between the 520 and 1040 systems? In general: yes, all ST chipsets (260,520,1040,MegaST, STacey) are interchangeable. IIRC there do exist 80pin SMD MMU and/or Glue. But these are soldered to the PCB. But better do not mix IMP and non-IMP manufactured ASICs. Thanks Ar...
by TeX38
Wed May 17, 2017 7:18 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

Question regarding the MMU,DMA and Glue chips.

Are these parts interchangeable between the 520 and 1040 systems?
by TeX38
Wed May 17, 2017 7:15 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

I assume you have the service manual? http://dev-docs.atariforge.org/files/MegaSTe_Service_Man_Jun-1991.pdf (actually contains all relevant service manuals) Before going after GLUE/MMU, since they are soldered in, check their clocks, and it's probably easier to check MFP and DMA first. As per the s...
by TeX38
Tue May 16, 2017 8:38 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

Love my Oscilloscope..

I have found D3 D6 and D9 to be faulty on my 1040 Making me suspect a buffer at fault.

Next to change the 74LS244 and 74LS373 suspects.
by TeX38
Fri May 12, 2017 5:24 am
Forum: Chat forum [ENG]
Topic: wanting to connect with other atari users in australia
Replies: 10
Views: 4076

Re: wanting to connect with other atari users in australia

Hi TeX38 Good to hear from another Atari fan in Queensland. There are a few of us here. Blaylok, Mikro, Gazak28 and I have been meeting monthly since late last year at Mikro's place to chat and play. At the last meetup we were joined by Christoph, so the group is growing. Would be good to see you th...
by TeX38
Tue May 09, 2017 11:34 pm
Forum: Chat forum [ENG]
Topic: wanting to connect with other atari users in australia
Replies: 10
Views: 4076

Re: wanting to connect with other atari users in australia

Hi blaylok I live in Maryborough Qld, not too far from you. How goes you? Will be good to talk to fellow Aussies regarding the Atari, I have 2 , a non working 1040STFM and a working 512STF from which I cannot get a colour picture. It is a French machine with French TOS and so far I have only been ab...
by TeX38
Tue May 09, 2017 11:14 pm
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

Did you made a cross check of Glue and MMU with known good ST?[/quote]

The MMU and GLUE are soldered to the board on my 1040, thinking to de-solder and replace with sockets.

The MMU and GLUE are socketed on my 512.
by TeX38
Tue May 09, 2017 7:55 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

Could it be a ROM fault? Loose socket, perhaps? Maybe, I am going to build a circuit to read each ROM using an Arduino to verify the chips. I have an ST board here with French Roms, I plugged the English Roms into it but it wouldn't boot. I also tried the French Roms in the 1040 but that failed as ...
by TeX38
Tue May 09, 2017 3:07 am
Forum: Hardware
Topic: 1040STFM Halted CPU
Replies: 30
Views: 6748

Re: 1040STFM Halted CPU

Is the HALT-Pin of CPU low? Have you already checked the reset circuit? Hi Lynxman, Yes, I removed the LS05 to see if it may be the reset circuit at fault, the Halt remains low and the Reset circuit is working per expected. The halt is Bi-Directional so the halt is being generated by the CPU. There...

Go to advanced search