Search found 1259 matches

by Chandler
Mon Jul 15, 2019 10:25 pm
Forum: Professionals
Topic: Dead Falcon - no boot / coloured screen only
Replies: 51
Views: 5520

Re: Dead Falcon - no boot / coloured screen only

keyboard attached and there is no blinking floppy LED
by Chandler
Sat Jul 13, 2019 9:57 pm
Forum: Professionals
Topic: Dead Falcon - no boot / coloured screen only
Replies: 51
Views: 5520

Re: Dead Falcon - no boot / coloured screen only

I get the same screen when using the falcon to ST adaptor on a Phillips cm 8833 screen in low res

The picture shown at the beginning of the thread comes up immediately almost

after changing the Combel i still get the same screen
by Chandler
Sat Jul 13, 2019 9:29 am
Forum: Hardware
Topic: Mega STE, white screen in colour mode or TV, black screen in high res
Replies: 18
Views: 1100

Re: Mega STE, white screen in colour mode or TV, black screen in high res

I have already checked all PLCC sockets are they are clean with no bent pins, chips also are clean with no bent pins
by Chandler
Fri Jul 12, 2019 6:12 pm
Forum: Professionals
Topic: Dead Falcon - no boot / coloured screen only
Replies: 51
Views: 5520

Re: Dead Falcon - no boot / coloured screen only

Defo no physical damage, i have been over the mobo with a magnifying glass already

No way i'm putting it in the oven!
by Chandler
Fri Jul 12, 2019 6:10 pm
Forum: Hardware
Topic: New Atari 1040 STf Owner-Keyboard beeping nonstop
Replies: 5
Views: 526

Re: New Atari 1040 STf Owner-Keyboard beeping nonstop

check for broken wires where the wires fix to the white plug on the keyboard
by Chandler
Wed Jul 10, 2019 8:45 pm
Forum: Hardware
Topic: Mega STE, white screen in colour mode or TV, black screen in high res
Replies: 18
Views: 1100

Re: Mega STE, white screen in colour mode or TV, black screen in high res

frank.lukas wrote:I have the same problem with my Mega STE.

The CPU are not working. So I have to check CLK, RESET and HALT on the CPU. I think one of the three 22V10 PAL/GALs are faulty, I not know?


Hey Frank

Do you get a white screen with black limes moving using a colour monitor or TV port?
by Chandler
Wed Jul 10, 2019 7:32 am
Forum: Hardware
Topic: Mega STE, white screen in colour mode or TV, black screen in high res
Replies: 18
Views: 1100

Re: Mega STE, white screen in colour mode or TV, black screen in high res

Looking at the crystals / Osc on the board there are 4 in total

U408 - C398767- 001 / 16.021226 MHZ
UA12 - C398107- 001 / 3.672MHZ
Y202 - C070176 - 001 / 32.084988
Y301 - C025993- 001 / 2.4576

Also another question i have is will a regular STE 8MHZ CPU work in the Mega STE?
by Chandler
Tue Jul 09, 2019 9:33 pm
Forum: Professionals
Topic: Dead Falcon - no boot / coloured screen only
Replies: 51
Views: 5520

Re: Dead Falcon - no boot / coloured screen only

I have also tested this board with the test cart and null modem cable using an ST as a terminal and nothing, no output

I have noticed the Falcon video DAC IC (small square IC next to the Videl) this DAC IC gets warm and quite hot after a while
by Chandler
Tue Jul 09, 2019 9:29 pm
Forum: Hardware
Topic: Mega STE, white screen in colour mode or TV, black screen in high res
Replies: 18
Views: 1100

Re: Mega STE, white screen in colour mode or TV, black screen in high res

OK so been playing with a couple of other terminal programs (TAZ and FLASH) and a null modem cable and i have the set up working using a working ST to test the set up So i connected the Mega STE mobo and switch it on and...nothing No text or data on the screen even after pressing reset a few times W...
by Chandler
Tue Jul 09, 2019 6:31 pm
Forum: Hardware
Topic: Mega STE, white screen in colour mode or TV, black screen in high res
Replies: 18
Views: 1100

Re: Mega STE, white screen in colour mode or TV, black screen in high res

Can you tell me what is this terminal program? is that the one that comes with the Language disk? VT52 Also what's the exact pinout for this cable? it says in the Falcon service manual pin 2 of (U.U.T) to pin 3 (of terminal) and vice versa and 5 to pin 7 So is this pin 5 of U.U.T to pin 7 of the ter...
by Chandler
Sun Jul 07, 2019 10:13 am
Forum: Hardware
Topic: SM 124 black screen BUT power LED ok and sound
Replies: 26
Views: 3168

Re: SM 124 black screen BUT power LED ok and sound

R712 value is just under 120 ohm so ok

As for powering up i'll have to re install the PCB again so will be back sometime soon...
by Chandler
Sun Jul 07, 2019 10:08 am
Forum: Hardware
Topic: Atari SC1224 Monitor not working
Replies: 6
Views: 1142

Re: Atari SC1224 Monitor not working

recap the power supply only first and see how that goes

The other issue is the LOPT (line output transformer) i had the same problem with mine, random switching on and off and that's what it was, failing LOPT

Could you post a picture of the power supply please?

Is yours a USA model or UK model
by Chandler
Sat Jul 06, 2019 8:55 am
Forum: Hardware
Topic: Mega STE, white screen in colour mode or TV, black screen in high res
Replies: 18
Views: 1100

Re: Mega STE, white screen in colour mode or TV, black screen in high res

So how do you set this up then? how do i get to read any data from the serial port
by Chandler
Fri Jul 05, 2019 7:41 pm
Forum: Hardware
Topic: Mega STE, white screen in colour mode or TV, black screen in high res
Replies: 18
Views: 1100

Re: Mega STE, white screen in colour mode or TV, black screen in high res

Hi

Thanks for your reply

Yes i know this about U501 and i have installed the IC correctly

The early type IC C300589-001 the IC marking relates to pin 1

The later IC C302183-001 fits the opposite way around

I have tried using a test cartridge but seeing as there is no desktop it's not of much use
by Chandler
Fri Jul 05, 2019 7:03 pm
Forum: Hardware
Topic: Mega STE, white screen in colour mode or TV, black screen in high res
Replies: 18
Views: 1100

Mega STE, white screen in colour mode or TV, black screen in high res

Another motherboard i've been trying to repair lately is this Mega STE PCB All it get is, a white screen (with black lines which look like they are moving / scrolling) when connected to either a TV or colour monitor or black screen when connected to high res No floppy drive activity ALL socketed IC'...
by Chandler
Fri Jul 05, 2019 12:38 pm
Forum: Professionals
Topic: Dead Falcon - no boot / coloured screen only
Replies: 51
Views: 5520

Re: Dead Falcon - no boot / coloured screen only

Well i finally go around the changing the Combel....... Sadly no change, same faulty screen appears :x I also changed the TV modulator for a UK PAL type, when plugged into the TV port the screen is black, however i also tested this with the TV without the memory card fitted and it gave a picture lik...
by Chandler
Thu Jul 04, 2019 9:09 pm
Forum: For sale / Wanted
Topic: WANTED: Mega STE HD or non HD panel
Replies: 2
Views: 438

WANTED: Mega STE HD or non HD panel

I'm looking for the removable hard drive panel for a Mega STE

I will also take the non hard drive panel as i basically have the panel missing so i would rather have either type fitted than a big hole ontop of the machine!

Yellowing is fine

If anyone can help let me know

thanks :)
by Chandler
Tue Jul 02, 2019 7:17 pm
Forum: Hardware
Topic: SM 124 black screen BUT power LED ok and sound
Replies: 26
Views: 3168

Re: SM 124 black screen BUT power LED ok and sound

OK so i have removed and tested both R605 and R707 and they are both good and measure the correct resistance
by Chandler
Fri Jun 28, 2019 1:01 pm
Forum: Hardware
Topic: SM 124 black screen BUT power LED ok and sound
Replies: 26
Views: 3168

Re: SM 124 black screen BUT power LED ok and sound

Thanks for your reply

I have removed and tested R608 which measures 30KOhm and R708 11KOhm

So they are both correct as these are the values given in the service manual
by Chandler
Wed Jun 19, 2019 8:50 pm
Forum: Hardware
Topic: SM 124 black screen BUT power LED ok and sound
Replies: 26
Views: 3168

Re: SM 124 black screen BUT power LED ok and sound

Actually thinking about it, i tested the other PCB i have and the B+ was 26.4V so i adjusted it to 27V Back to this non working PCB with 33V B+ this doesn't seem right as adjusting it back to 27V the adjustment pot was at the minimal setting and can't go back any further Could something be causing t...
by Chandler
Tue Jun 18, 2019 6:49 pm
Forum: Hardware
Topic: SM 124 black screen BUT power LED ok and sound
Replies: 26
Views: 3168

Re: SM 124 black screen BUT power LED ok and sound

checked for 27V at C714 and it was 33V, so i adjusted the B+ pot back to 27V

Still no joy, but at least i know the power supply is ok i guess
by Chandler
Fri Jun 07, 2019 7:59 pm
Forum: For sale / Wanted
Topic: TT internal metal square speaker housing
Replies: 3
Views: 682

Re: TT internal metal square speaker housing

Yes that's it

I have sent you a PM
by Chandler
Fri Jun 07, 2019 1:46 pm
Forum: For sale / Wanted
Topic: TT internal metal square speaker housing
Replies: 3
Views: 682

TT internal metal square speaker housing

I've been slowly restoring a TT for ages and i'm missing just 1 part The small square metal box that the internal speaker fits into it sits ontop of the VME metal housing I know it's not much used for anything the speaker but i'm just trying to keep it all original I have the speaker, i just need th...
by Chandler
Thu May 09, 2019 8:47 pm
Forum: Professionals
Topic: Scope needed for fault finding - any advice on which type?
Replies: 0
Views: 667

Scope needed for fault finding - any advice on which type?

I'm looking for a scope to try and diagnose a dead Falcon

I'm just looking for something simple and basic, portable with simple LCD type screen (if such a thing exists)

Can anyone advise or recommend anything?

:)

Go to advanced search